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Style: A style is a set of formats that you can apply to selected pages, text,
frames, and other elements in your document to quickly change their
appearance.
OpenOffice.org supports the following types of styles:
Page styles include margins, headers and footers, borders and backgrounds.
In Calc, page styles also include the sequence for printing sheets.
Paragraph styles control all aspects of a paragraph’s appearance, such as
text alignment, tab stops, line spacing, and borders, and can include
character formatting.
Character styles affect selected text within a paragraph, such as the font
and size of text, or bold and italic formats.
Frame styles are used to format graphic and text frames, including wrapping
type, borders, backgrounds, and columns.
Numbering styles apply similar alignment, numbering or bullet characters,
and fonts to numbered or bulleted lists.
Cell styles include fonts, alignment, borders, background, number formats
(for example, currency, date, number), and cell protection.
Graphics styles in drawings and presentations include line, area, shadowing,
transparency, font, connectors, dimensioning, and other attributes.
Presentation styles include attributes for font, indents, spacing, alignment,
and tabs.

Click the Styles and Formatting icon      located at the left-hand end of the
object bar, or click Format > Styles and Formatting, or press F11. The
Styles and Formatting window shows the types of styles available for the
OpenOffice (OpenOffice.org) component you are using.

Using the Styles and Formatting window(Step by Step)
1.

SESSION 1: CREATE AND APPLY STYLES IN THE
DOCUMENT

Applying styles

Click on one of the icons at the top left of the       
Styles and Formatting window to display a list      
of styles in a particular category.

2.

To apply an existing style (except for character
styles), position the insertion point in
the paragraph, frame, or page, and then 

double-click on the name of the style in one of these lists. To apply a character
style, select the characters first.

3.



Using Fill Format mode

Open the Styles and Formatting window and select the style you want to apply.
Click the Fill Format mode icon
To apply a paragraph, page, or frame style, hover the mouse over the paragraph,
page, or frame and click. To apply a character style, hold down the mouse button
while selecting the characters, clicking on a word applies the character style for
that word. Repeat step 3 until you made all the changes for that style.
To quit Fill Format mode, click the Fill Format mode icon again or press the Esc
key. An important point to note here is that when this mode is active, a right-click
anywhere in the document undoes the last Fill Format action. Be careful not to
accidentally right click and thus undo actions you want to keep.

Fill format mode is used to apply a style to many different areas quickly without
having to go back to the Styles and Formatting window and double-click every time.
This method is quite useful when you need to format many scattered paragraphs,
cells, or other items with the same style.

1.
2.
3.

4.

Creating a new style from a selection

Open the Styles and Formatting window and choose the type of style you want to
create.
In the document, select the item you want to save as a style. 
In the Styles and Formatting window, click on the New Style from Selection icon.

You may want to add some new styles. You can do this in two ways:

You can create a new style by copying an existing manual format. This new style
applies only to this document; it will not be saved in the template.

1.

2.
3.

(Refer to below figure)

Creating New (Custom) Styles

Naming a new style created from a selection

In the Create Style dialog, type a name
for the new style. The list shows the
names of existing custom styles of the
selected type. Click OK to save the
new style.

4.

Dragging And Dropping To Create A Style
You can drag and drop a text selection into the Styles and Formatting window to
create a new style.
Select some text and drag it to the Styles and Formatting window. If Paragraph
Styles are active, the paragraph style will be added to the list. If Character Styles
are active,the character style will be added to the list.



Updating a style from a selection
Load or copy styles from another document or template

Modifying Styles
OpenOffice.org provides several ways to modify styles (both the predefined styles and
custom styles that you create):

1.
2.

Open the Styles and Formatting window
In the document, select an item that has the format you want to adopt as a
style

Updating A Style From A Selection

Open the document you want to copy styles into.
In the Styles and Formatting window, long-click on the arrow next to the New
Style from Selection icon, and then click on Load Styles

Loading Styles From A Template Or Document
You can copy styles by loading them from a template or another document:

In the Styles and Formatting window,
select the style you want to update
(single click, not double-click), then long-
click on the arrow next to the New Style
from Selection icon and click on Update
Style

Copying styles from a template into the open document

On the Load Styles dialog,
find and select the

template you want to
copy styles from.

Select the categories of styles to be copied. Select Overwrite if you want the
styles being copied to replace any styles of the same names in the document
you are copying them into. 
Click OK to copy the styles. You will not see any change on screen

To copy the styles from another document, click the From File button to open a
window from which you can select the required document.



Inserting An Image File

Drag and Drop
Open a file browser window and locate the image you want to insert
Drag the image into the Writer document and drop it where you want
it to appear. A faint vertical line marks where the image will be
dropped

Insert Picture Dialog
Click in the Open Office document where you want the image to
appear.
Choose Insert > Picture > From File from the menu bar.
On the Insert Picture dialog, navigate to the file to be inserted, select it,
and click Open.

Inserting An Image From The Clipboard

Open both the source document and the target document.
In the source document, select the image to be copied
Move the mouse pointer over the selected image and press Ctrl+C to
copy the image to the clipboard.
Switch to the target document
Click to place the cursor where the graphic is to be inserted.
Press Control+V to insert the image.

Images can be added to a document in several ways: by inserting an image file,
directly from a graphics program or a scanner, or from the Open Office Gallery.

When the image is in a file stored on the computer, you can insert it into an
Open Office document using either of the following methods:

Using the clipboard, you can copy images into an Open Office document
from another Open Office document and from other programs. To do
this:
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At the bottom of the dialog are
two options, Preview and Link.

Select Preview to view a
thumbnail of the selected

image on the right, so you can
verify that you have the correct

file. See below for the use of
Link



Inserting An Image Using A Scanner

Insert > Picture > Scan > Select Source
Inserting An Image From The Gallery

To open the Gallery, click on the Gallery icon       (located in the right
side of the Standard toolbar) or choose Tools > Gallery from the menu
bar.
Navigate through the Gallery to find the desired picture.
To insert the picture, click and drag it from the Gallery into the Writer
document. You can also right-click on the picture and choose
Insert>Copy.

If a scanner is connected to your computer, Open Office can call the
scanning application and inserted the scanned item into the Open Office
document as an image.

By default, the Gallery is docked
above the Writer workspace. To

expand the Gallery,
position the pointer over the line
that divides it from the top of the

workspace. When
the pointer changes to parallel
lines with arrows, click and drag

downward. The
workspace resizes in response. 

Using The Picture Toolbar

Graphics mode

Modifying An Image
We will discuss the use of the Picture toolbar, resizing, cropping, and a
workaround to rotate a picture.

When you insert an image or select one already present in the
document, the Picture toolbar appears. You can set it to always be
present (View > Toolbars > Picture). Picture control buttons from the
Picture toolbar can also be added to the Standard Toolbar.

You can change color images to grayscale by selecting the image and then
selecting Grayscale from the Graphics mode list. 



Flip vertically or horizontally

Filters

Transparency 

To flip an image vertically or horizontally, select the image, and then click
the relevant icon.

Following table includes some of the available filters in OpenOffice.

Modify the percentage value in the Transparency box on the toolbar to
make the image more transparent. This is particularly useful when creating
a watermark or when wrapping the image in the background.

Cropping Images
When you are only interested in a section of the image for the purpose of your
document, you may wish to crop (cut off) parts of it. To start cropping the image,
right click on it and select Picture from the pop-up menu. In the Picture dialog box,
select the Crop page.

Keep scale / Keep image size
Left, Right, Top, and Bottom
Width and Height
Resizing an Image

In the Crop page, you can control the
following parameters: 



Keep scale / Keep image size

Left, Right, Top, and Bottom

When Keep scale is selected, the size of the image also changes, so in this
example the width will be reduced by 3 cm.
When Keep image size is selected, the remaining part of the image is enlarged
(when you enter positive values for cropping) or shrunk (when you enter
negative values for cropping) so that the width and height of the image remains
unchanged.

Width and Height

Resizing an Image

Click the picture, if necessary, to show the green resizing handles
Position the pointer over one of the green resizing handles. The pointer
changes shape giving a graphical representation of the direction of the resizing.
Click and drag to resize the picture.
Release the mouse button when satisfied with the new size.

Rotating a Picture

Open a new Draw or Impress document 

Insert the image you want to rotate. You can use any of the mechanisms
described in “Error! Reference source not found.” on page Error! Bookmark not
defined., although there are some slight variations in the position of the menu
entries and icons.
Select the image, then in the Drawing toolbar (shown by default at the bottom
of the window in Impress and Draw), select the Rotate icon     from the Effects
tear off toolbar.
Rotate the image as desired. Use the red handles at the corners of the picture
and move the mouse in the direction you wish to rotate. By default the picture
rotates around its center (indicated by a black crosshair), but you can change
the pivot point by moving the black crosshair to the desired rotation center.

When Keep scale is selected (default), cropping the image does not change the
scale of the picture. When Keep image size is selected, cropping produces
enlargement (for positive cropping values), shrinking (for negative cropping values),
or distortion of the image so that the image size remains constant. 

The image is cropped by the amount entered in these boxes. For example, a value
of 3cm in the Left box cuts 3 cm from the left side of the picture.

The Width and Height fields under either Scale or Image size change as you enter
values in the Left, Right, Top, and Bottom fields. Use the thumbnail next to these
fields to determine the correct amount by which to crop.

The inserted image might not fit perfectly into the document if it is too big or too
small. In these cases, you can use Writer to resize the image.

Writer does not provide a tool for rotating a picture; however, there is a simple
workaround: 

(File > New > Drawing or File > New > Presentation).



To restrict the rotation angle to multiples of 15 degrees keep the Shift key pressed
while rotating the image.
Select the rotated picture by pressing Ctrl+A, then copy the image to the clipboard
with Ctrl+C.
Finish by going back to the location of the Writer document where the image is to
be inserted and pressing Ctrl+V.

Creating Drawing Objects

Click in the document where you want the drawing to be anchored. You can
change the anchor later, if necessary.
Select the tool from the Drawing toolbar. The mouse pointer changes to a drawing-
functions pointer .
Move the cross-hair pointer to the place in the document where you want the
graphic to appear and then click-and-drag to create the drawing object. Release
the mouse button. The selected drawing function remains active, so you can draw
another object of the same type.
To cancel the selected drawing function, press the Esc key or click on the Select
icon (the arrow) on the Drawing toolbar.
You can now change the properties (fill color, line type and weight, anchoring, and
others) of the drawing object using either the Drawing Object Properties toolbar or
the choices and dialog boxes reached by right-clicking on the drawing object.

Set or Change Properties For Drawing Objects

On the Drawing toolbar (Figure Given Below), click the Select tool.
On the Drawing Object Properties toolbar, click on the icon for each property and
select the value you want for that property.
For more control, or to define new attributes, you can click on the Area or Line
icons on the toolbar to display detailed dialog boxes.

To begin using the drawing tools, display the Drawing toolbar, by click in View >
Toolbars > Drawing.
 
 
 
 
 
 
 
 
To use a drawing tool:

To set the properties for a drawing object before you draw it:



Select the object.
Continue as described above.

Right-click on the drawing object and then click Position and Size from
the popup menu. The Position and Size dialog box is displayed.
Choose any properties, as required.

Select Format > Object > Position and Size from the menu bar.
Use the Position and Size dialog box to set the width and height
independently.
If the Keep ratio option is selected, then the two dimensions change so that
the proportion is maintained, allowing for a scaled resizing.

Select one object, then hold down the Shift key and select the others you
want to include in the group. The bounding box expands to include all the
selected objects.
With the objects selected, hover the mouse pointer over one of the objects
and choose Format > Group > Group from the menu bar or right-click and
choose Group > Group from the pop-up menu.

Arrangement refers to the placement of a graphic on an imaginary vertical
axis. Arrangement controls how graphics are stacked upon each other or
relative to the text.
Alignment refers to the vertical or horizontal placement of a graphic in

l h h h

The default you set applies to the current document and session. It is not
retained when you close the document or close Writer, and it does not apply to
any other document you open. The defaults apply to all the drawing objects
except text objects. 
To change the properties for an existing drawing object:

a.
b.

You can also specify the position and size, rotation, and slant and corner radius
properties of the drawing object:

Resizing a Drawing Object
The same considerations for resizing an image apply also to resizing an object.
For a scaled resizing, select one of the corner handles and keep the Shift key
pressed while dragging the handle to its new position.
For more sophisticated control of the size of the object,

Grouping Drawing Objects
To group drawing objects:

1.

2.

Easier Way is by choosing the objects and then using the shortcut key ctrl + G.
Positioning Image/Graphics Within The Text
When you add a graphic to a text document, you need to choose how to
position it with respect to the text and other graphics.
Positioning of a graphic is controlled by four settings:



Anchoring refers to the reference point for the graphics. This point could be the
page, or frame where the object is, a paragraph, or even a character. An image
always has an anchor point.
Text wrapping refers to the relation of graphics to the surrounding text, which
may wrap around the graphic on one or both sides, be overprinted behind or in
front of the graphic, or treat the graphic as a separate paragraph or character.

From the Format menu, where you can find Alignment, Arrange, Wrap, and
Anchor (both for images and drawing objects)
From the pop-up menu displayed when you right-click on the graphic
For images, from the Type and Wrapping pages of the Picture dialog box. Note
that you cannot control the arrangement using the dialog box. To open the
Picture dialog box, click on the image to select it and then choose Format >
Picture or right-click on the graphic and choose Picture on the pop-up menu.
For drawing objects, from the Position and Size page of the Position and Size
dialog box. To open the Position and Size dialog box, click on the drawing object
to select it and then choose Format > Object > Position and Size or right-click
on the graphic and choose Position and Size on the pop-up menu. Note that
you can only control the alignment and anchoring.

The settings can be accessed in a number of ways, depending on the nature of the
graphics:

1.

2.
3.

4.



Text, Heading, Header/Footer
Graphics( Images, Videos, etc)
A set of styles
Default Printer
Language
Toolbar settings
Any many such more things.

Creating A Template From A Document

Open a new or existing document of the type you want to make
into a template
Add the content and styles that you want.
From the main menu, choose: File > Templates > Save.

What is Template?
A template is a model that you use to create other documents. For
Example, If your school makes your school worksheets which have same
layout in all with its logo and address. How hard it would be to clone it
again and again in the file with same changes. So here you can use
Template which will give the logo and basic information to all the files.

Templates can contain: 

Creating a Template
You can create your own templates in two ways: from a document, and
using a wizard.

To create a template from a document:
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Templates dialog box

In the New template field, type a
name for the new template.

In the new Document wherever you
want to use the template follow this:

1.

In the Categories list, click the category to which you want to assign the
template. The category you choose has no effect on the template itself; it is
simply the folder in which you save the template. Choosing an appropriate
category makes it easier to find the template when you want to use it. 

2.



3. Click OK to save the new template.

Creating A Template Using A Wizard
From the main menu, choose File > Wizards >>template Type

Follow the instructions on the
pages of the wizard. This process is
slightly different for each type of
template, but the format is very
similar.
In the last section on the wizard you
decide where to store the template.
Finally, you have the option of
creating a new document from your
template immediately, or manually
changing the template.

From the main menu, choose File > Templates > Organize. The Template
Management dialog opens.
In the box on the left, select the folder containing the template that you
want to set as the default, then select the template.
Click the Commands button and choose Set As Default Template from
the dropdown menu.

In the Template Management dialog, click any folder in the box on the
left.
Click the Commands button and choose Reset Default Template from the
dropdown menu.

Setting A Default Template
You can set any template to be the default, as long as it is in one of the
folders displayed in the Template Management dialog.
To set a custom template as the default:

1.

2.

3.

Now whenever you open the document you will get the template as the one
you set it default.
Resetting the default template
To reset back to default template, simply follow following steps:

1.

2.



When you create your document, use the following paragraph styles for
different heading levels (such as chapter and section headings): Heading 1,
Heading 2, and Heading 3. These are what will appear in your table of
contents. You can use more levels of headings, but the default setting is to
use only the first three levels in the table of contents.
Place the cursor where you want the table of contents to be inserted.
Select Insert > Indexes and Tables > Indexes and Tables.
Change nothing in the Insert Index/Table dialog. Click OK.

Setting Basic Attributes
From the Type drop-down list in the Type and title area of the tab, select
Table of Contents if it isn't already selected.
From the drop-down list in the Create index/table area, select Entire
document. In the Create from area, check the Outline check box.
In the Create from area, clear the Index marks check box.

Basically here we will learn how to make index in Open Office Document. In Open
Office we have a direct feature to make Table of Content. Simply follow the
following steps:

1.

2.
3.
4.

If you make any changes in headings or if you add some more content and your
page number changes than you will need to update the Table of Content. Follow
this steps to make changes in the Table of Content:

Using the Index/Table tab
You can set Image Attribute in Table of Content/Index. This way you customize
the Index.

SESSION 4: CREATE AND CUSTOMIZE TABLE OF
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Place the cursor
within the table of
contents.
Right-click and select
Update Index/Table
from the pop-up
menu.

1.

2.



Adding A Title

Protecting Against Manual Changes

Changing The Number Of Levels

Assigning Custom Styles

In the Create from area, check the Additional Styles check box.
Click the (...) button to the right of the check box. The Assign Styles
window opens.
In the Not applied column, click the style that you want to assign to the
table of contents

If you'd like the table of contents to have a title, enter it in the Title field. (If
Writer entered a title in this field automatically, you can change it by simply
typing over the value.) To delete the title, clear the Title field.

To protect the table of contents from being changed accidentally, check the
Protected against manual changes check box.

By default, Writer evaluates 10 levels of headings when it builds the table of
contents. To change the number of levels evaluated, enter the desired
number in the Evaluate up to level spin box.

Writer automatically assigns to the table of contents all paragraphs formatted
with the default heading styles (Heading 1, Heading 2, and so on). To assign
paragraphs formatted with custom styles, follow these steps:

Use the >> button to move the selected
style to the desired outline level. For
example, if you want paragraphs
formatted with the selected style to
appear as toplevel entries in the table
of contents, click the >> button once to
move the style into the 1 column. To
move the style in the opposite
direction, use the << button.

Click OK to save your changes and return to the Index/Table tab. Or, click
Cancel to return without saving your changes.

Using The Entries Tab
Use the Entries tab, to format the entries in the table of contents. For each
outline level, you can add and delete elements, such as chapter numbers,
and you can also apply character styles to individual elements.
To begin, click a level number in the Level column to select the outline level
whose elements you want to format. The Structure line displays the
elements for entries in that level. Each button on the Structure line
represents one element:



E# -- chapter number.
E -- entry text.
T -- tab stop.
# -- page number
LS -- start of a hyperlink.
LE -- end of a hyperlink.

Each white field on the
Structure line represents a
blank space.

To view or edit the attributes of a character style, select the style from the
Character Style drop-down list and then click the Edit button

Deleting Elements

Adding Elements

Place your cursor in the white field to the left of where you want to
insert the element.
Click one of the five buttons that are just below the Structure line.
(For example, to add a tab stop, click the Tab stop button.) A
button representing the new element appears on the Structure
line.

Applying Character Styles

On the Structure line, click the button that represents the element
to which you want to apply a style.
From the Character Style drop-down list, select the desired style.
Writer applies the selected style to the selected element.

To delete an element from the Structure line, click the button that
represents that element and then press the Delete key on your
keyboard. 

To add an element to the Structure line, follow these steps:

NOTE: If you insert a hyperlink, you must indicate both the beginning
and end of the link.

To apply a character style to an element on the Structure line:



Applying Changes To All Outline Levels

Using The Styles Tab

In the Levels list box, select the desired outline level by clicking it.
In the Paragraph Styles list box, click the paragraph style that you want to
apply.
Click the < button to apply the selected paragraph style to the selected
outline level.

Using The Background Tab

To apply the displayed structure and formatting to all outline levels, click the all
button.

To apply a paragraph style(Its a type of style, Recall it by going to 1st page) to an
outline level, follow these steps:

Use the Background tab, to add color or a graphic to the table background.
To add color to the background of the table of contents, simply click the desired
color in the color grid. (Look at the below image)

Adding A Graphic

Click the Browse button. The Find Graphics window opens.
Find the graphic file that you want to use and then click the Open
button. The Find Graphics window closes and the selected graphic
appears in the graphic preview box on the right-hand side of the
Background tab. (If you don't see the graphic, check the Preview
check box underneath the graphic preview box.)
In the Type area of the Background tab, choose how you want the
background graphic to appear:

To position the graphic in a specific location in the background,
select Position and then click the desired location in the
position grid.

From the As drop-down list, select Graphic. The Background tab
displays the graphics options.



To stretch the graphic so that it fills the entire background area,
select Area.
To repeat the graphic across the entire background area, select Tile.

Updating A Table Of Contents

Click anywhere in the table of contents and then right click. The context
menu appears.
From the context menu, choose Update Index/Table. Writer updates the
table of contents to reflect the changes in the document.

Deleting A Table Of Contents
To Delete the Table of Contents, right click on the table and then choose
Delete Index/Table. Writer would delete the Table of Content.

To update a document's table of contents when changes are made to the
document:



SESSION 5: IMPLEMENT MAIL MERGE
Mail Merge: The automatic addition of names and addresses from a
database to letters and envelopes in order to facilitate sending mail,
especially advertising, to many addresses.
You can use Mail Merge in Printing Letters for multiple users with different
names and addresses at the same time. 

Open a template, if you have one you want to use, or create a new Writer
document.
Save the document with the appropriate name, like
mailmerge_openenrollment.ods or mailmerge_parents.odt.
Write out the text that will be going to everyone, and plan where you want
the fields. For instance, you might know that you are going to have an
address block at the top of the letter, so you’ll leave a few blank lines for
that. Then you’d write something like this, know that you’d add the fields
firstname and years_of_service later:

If you’re doing anything complex and this is your first mail merge letter,
write out the letter completely as you want it to read including sample
data. Use all the text, including samples for firstname, lastname, etc. This
will help you determine which fields you need to use, where you need
spaces before and after fields, etc. In the following example, for instance, if
you want to communicate this, you’ll need to use fields from the database
for title, lastname, childs_name, study_area, and test_score.

Create a Mail Merge Document: Letter

Dear ,
Remember that next month is open enrollment for benefits. Employees with
over five
years of experience are also eligible for sabbatical; you have been with us for
years so
please get your application in early if you plan to apply.
Regards,
Human Resources

Dear Ms. Smithson,
Your child Jenny is such a joy to have in the classroom. Her score on her Social
Studies test score last Friday was A-.
Regards,
Mr. Thomson



Once you have the letter written out and you know what fields you need,
you can delete the specific data like “Ms. Smithson” and insert the fields
from the database instead.

Choose File > New > Database. You’ll see this window:

To Make The Data Source And Entering Data
OpenOffice.org is set up with a middle-man file in the mail merge process to
make merging work easily. You’ll create a small file, one for each
spreadsheet or other data source. Once you create it, you don’t have to do it
again.

Select the type of data:
spreadsheet data, text file data,
your particular type of address
book, or the type of database
you’re using like Access or mySQL.
It’s very important to select the
right type. Click Next.

What you do here depends on
what you chose as the type of data
you’re working with.

Spreadsheet
You’ll see this window. Click
the Browse button and find
the spreadsheet containing
your data. Then click Next and
continue to next step.

Text File
You’ll see this window(In Next Page) . Click the Browse button and find the
directory containing your text files.



Fill out the rest of the
information:
Specify the type of files you want
to access: Specify whether the file
name ends in .txt or .csv.

Microsoft Access
You’ll see this window. Click the Browse button and find the .mdb Access file
containing your data.

In this window, just be sure to keep the option for registering selected.
Unmark the selection to open the database for editing unless you want to
see the database editing window. (You don’t need to unless you want to
make a query or other database-related item, which we haven’t talked
about yet.)

(IMAGE IN NEXT PAGE)



Click Finish.
You’ll be prompted to save
the database file. Name it
something very
descriptive; this
is the name you’ll be
looking for when you’re
adding database files to
your mail merge
documents.

You can see your databases by pressing F4 when you’re in a Writer or Calc
document. Click the + icon next to the database you created to see the items
named Queries and Tables. Click the + next to Tables to see the tables you
created; select a table to see the data in it.
When you’re done viewing your databases, press F4 again to hide the panel.
You’re done creating the database file. You only need to do this once for
every spreadsheet, database, or directory of text files.

Open the letter you want to use.
Once you have the letter written out and you know what fields you need,
you can delete the specific data like “Ms. Smithson” and insert the fields
from the database instead. Press F4. Click the + next to the database you
want, then click the + next to Tables and the + next to the table you want.

Merging The Data Source With Main Document



Now just drag the field you want into the letter, to the place you want it.
Click and hold down on the name of the first field you want. Don’t
click on the data, like Smithson; click on the name of the field, like
lastname.
Drag the field name into the letter to the place where you want it.
The mouse will have a + attached to it as shown.

a.

b.

If you didn’t get it exactly where you want it, just select it, and cut and
paste it to the place where you want it. The easiest way to select a field is
to click on the right side of it, hold down the Shift key, and press the left
keyboard key once. Then it’s selected and you can cut or copy.
Drag in all the other fields you want, the same way. If you want a field in
the letter twice, you can drag it twice, or drag it in once, then copy and
paste it to the other location.
The fields should display with a gray background, as shown. It won’t print;
it just helps you see which text is from the database and which text you
typed.
Format the document any way you want it. The fields respond to
formatting the same way that normal text does.
You’re done creating the mail merge document. You only need to do this
once. The next step is to either print the letter to a printer, or “print” to a
Writer file so you can see all the data merged, and so you can customize,
before printing on paper. Continue to the printing step.

Editing a saved file of mailing labels

To edit a saved file of mailing labels, open the saved label file in the normal
way. You will be prompted to update all links. Choose No for the following
reason: The first label on the page is termed the “Master Label” and all other
labels are linked to it. If you update the links, then all labels will end up
containing the same data, which is probably not what you want. You can edit
individual records in the normal way, by highlighting and changing the font
name, for example. 


